Skip to content

FIX: Supermicro X9SCM-F second lan card BUG

June 5, 2012

Supermicro X9SCM-F has eeprom bug in the bios:

Fbsd dmesg shows:

Setup of Shared Code failed

device_attach: em0 attach rerned 6

this is how it looks on freebsd and linux, and when you enable the LanCard #2 ROM from the bios:

This is the bios message, when lan rom is enabled on land card #2:

SuperMicro X9SCM/X9SCM-F second lan card bug - bios view

SuperMicro X9SCM/X9SCM-F second lan card bug – bios view

This is the Live Linux /backtrack in my case, but it’s same on all/ lspci and dmesg view:

This is the Live Linux lspci and dmesg view:

This is the Live Linux lspci and dmesg view

This is the FreeBSD dmesg view:

This is the FreeBSD dmesg view

This is the FreeBSD dmesg view

As we see on the FreeBSD, there is error:

Setup of Shared Code failed

device_attach: em0 attach rerned 6

 

THE Solution:

1. Make MS-DOS bootable USB FLASH /floppy or cd/

2. Download the bios eeprom firmware , i have from my hardware provider, but you can google it: “X9SCL.zip”  , and copy it to the boot media

3. Boot ms-dos , start: X9SCLF.BAT

3.1 enter the first lan card mac address /it’s on a label on the mother board/

3.2 enter fir second lan card mac address /it’s on the same label/

reboot

That’s all.

Advertisements

From → Crash - Quick

One Comment
  1. Seems like you can’t google this zip. Can you upload it somewhere?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: